GM Active Fuel Management Headache

We bought our 2008 Chevrolet Suburban LT in the summer of 2011. It had 74,000 miles on the clock and we paid about half of what it cost new. We lived in Florida at the time so it was perfect for us, a family of 5 plus a dog, to use on our trips back to Michigan to see our extended family. It has been a great family hauler, making our extended road trips across the country very comfortable, it made several trips to Michigan and Texas (our new home) without any trouble. That changed during our Christmas trip to Michigan in 2012. When we got to Michigan, it was cold, really cold. I noticed a lifter tick when the engine was started that I had never heard before, it diminished after the truck warmed up, so I assumed that the cold weather was causing the noise. Over the course of our 10 day visit, the tick became more pronounced, but would still diminish after the engine warmed up. Still convinced that the issue was cold weather related, we headed home for Texas. Somewhere in Kentucky the check engine light came on. So we pulled off at the next exit to check everything out, there was no smoke or smells, the oil level was good, (I had just changed it before the trip with Mobile 1 5w30), but there was the slight ticking sound that now never completely went away. Concerned by the tick, but determined not to spend a fortune to have a shop look at it on the road, we pressed on. The light stayed on, but no other issues developed, we made it home without incident.

After we unpacked and were settled, I put a code reader on the Suburban to find out what the check engine light was about. “Misfire on cylinder 6”, seemed like a strange error to me. The truck had never made any noise that sounded like a misfire to me, and it had plenty of power all the way through its rpm range. To trouble shoot, I swapped out the coils from the other cylinder bank, then the wires, then the plugs, each time clearing the code only to see it return to cylinder number 6.  Completely confused by this, I started looking online to see what a “Misfire on cylinder 6” meant for a GM 5.3 liter engine. What I found were numerous posts on multiple forums complaining about the Active Fuel Management (AFM) system on these engines. The posts talked about the AFM lifters failing or worse, on some aluminum blocked versions of these engines there can significant blow-by of oil past the piston rings, clogging the plugs. Since my 5.3 has an iron block, and the plugs I had swapped were clean, I focused on the lifters.

I needed to remove and inspect the lifters to determine what, if anything, was wrong. Since I did not have a manual, I decided to look online for any write-ups on 5.3 liter engine dis-assembly and assembly. While I did not find any good write-ups for the 5.3, I did find an excellent write-up on LS1Howto.com regarding head/cam swaps for Gen III LS1 engines here:

http://ls1howto.com/index.php?article=1

The LS1 is a different engine then the 5.3, but it’s based off a similar engine design, and it has the same dis-assembly and assembly procedures. Using the information from the link above, I removed the intake and heads, after removing the heads I could remove the lifters.

Head Off

Since the number 6 cylinder is were the trouble code pointed to, I started with the intake and exhaust lifters for that cylinder. Both of the lifter’s rollers were pitted, which means the rollers were slapping against the cam. Climbing on top of the engine, I used a flashlight to look down at the cam though the lifter opening. Sure enough, the cam was pitted as well. I had to remove all of the lifters and the cam, below is a picture of the damage:

lifters_cam

So here I am with a busted GM engine with only 110,000 miles on the clock. Needless to say I was a bit peeved. I have owned GM cars for most of my life, and while the build quality of the body or interior could be spoty at times, the engines have always been bullet proof. I have several GM engines with well over 150,000 miles and still going strong. My old ’93 Yukon had a quarter million miles on it before the transmission quit, but the engine was still in great shape. I was really frustrated with this engine for breaking so soon, particularly with the fact the motor ran so well before the lifters failed.

f2061392

After taking the motor apart,  I spent a lot of time researching AFM, how much replacement lifters cost, their likelihood of future failure, I decided I did not like AFM very much. AFM lifters cost $40 ea. and the cam costs $225. Total for the cam and a set of lifters was north of $500, and then there was no guaranty the Valve Lifter Oil Manifold (VLOM) was not the cause of the lifter failure in the first place. All in all the system is too complicated in my opinion, so I decided to remove AFM from my engine and be rid of its troubles for good.

I spent a lot of time researching how to remove AFM from the engine, more time than my wife would have liked since she had to drive our old ’94 Yukon (160,000 miles on it) in the mean time. An online search revealed many opinions, and options for removing the AFM, or performing a “DOD delete” on these engines. Below is what I did:

Replaced all of the lifters with LS7 lifters. (GM Part # 12499225)
Replaced the old AFM lifter trays with LS2 lifter trays (GM Part # 12595365)
Replaced the cam with cam for Hummer H3 Alpha 5.3 (non-DOD) (GM Part # 12625437)
Removed the VLOM and replaced it with an LS3 valley cover. (GM Part # 12599296)

All the parts, including new head bolts and all the gaskets, ended up costing about $650.

f1458128

After everything was all put together this is what the engine sounded like:

I was pretty happy, but based on what I had read online this was not all there was to do. I had capped and taped the harness that ran to the VLOM. With it disconnected, the engine idled fine, but I decided to take it for a test drive to see what the computer would do without the VLOM installed.  Pulling out of the sub, the truck had no power, it would drive, but had absolutely no power. With the check engine light on, we turned around and drove the truck back home. I did not write the codes down, but there were several if I remember correctly, it was complaining about either missing or non-responsive VLOM solenoids, in response to these error codes the computer put the truck in “limp mode” which severely limited the power output of the engine.

After checking the codes, I used “HP Tuners” to program out AFM for the engine.

HP Tuners

This configures the computer to not use AFM or any of its components. After AFM was programmed out we took the truck for a second test ride, this time it ran great with no loss of power, and better yet it was always in V8 mode. No trouble codes returned.

In the time since AFM was removed I have been pleasantly surprised to see no reduction in fuel economy. The truck averaged 16 miles per gallon (we do mostly city driving) before the AFM system was removed, and it averages 16 mpg now. One has to wonder if the whole AFM gimmick is just a way for GM, in a controlled evaluation environment, to boost their truck mpg ratings for their CAFE numbers. As it certainly did not give us any real world mpg advantage, it just gave us a more fragile engine.  We’ve had over 27,000 trouble free miles since the rebuild was completed in January 2013. The Suburban has over 137,000 miles on it now, and without the specter of another AFM lifter failure in its future.

This entry was posted in General. Bookmark the permalink.